ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22705] - ant 1.6alpha (and possibly earlier) requires JDK 1.4
Date Mon, 25 Aug 2003 22:51:54 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22705>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22705

ant 1.6alpha (and possibly earlier) requires JDK 1.4





------- Additional Comments From stevel@apache.org  2003-08-25 22:51 -------
I've encountered this before; it is as Eric observed in his second comment -the
append(StringBuffer) method is new, and if your code compiles against the 1.4
version, it wont run against older versions.

the other fix is to cast the buffer to Object :-

description.append( (Object)descComp );

Eric, note that release builds have historically been made in a very complex
way, which involves downlevel java versions at the right time to compile java1.1
code, java1.4 only to build the 1.4 specific bits. Release versions of ant would
not have exhibited this problem, only nightly Gump builds. And we recommend you
build your own in those situations, as the nightly builds often miss out on
useful optional stuff. Thank you for finding the bug, however, as it is one of
those sublties that could have caught us out.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message