ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22657] New: - [PATCH] runant.py should use ant-launcher.jar
Date Fri, 22 Aug 2003 13:24:59 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22657>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22657

[PATCH] runant.py should use ant-launcher.jar

           Summary: [PATCH] runant.py should use ant-launcher.jar
           Product: Ant
           Version: 1.6Alpha (nightly)
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Enhancement
          Priority: Other
         Component: Wrapper scripts
        AssignedTo: dev@ant.apache.org
        ReportedBy: knut@paranor.ch


As of version 1.6 Ant sets up the classpath from within Java before actually 
starting Ant.  The wrapper scripts just have to include the ant-launcher.jar 
and run the class org.apache.tools.ant.launch.Launcher (or even use the -jar 
switch).

The Unix and Windows scripts have been adapted, but the other scripts, 
including the Python runant.py, not.

Attached is a patch for runant.py which makes the script:

 - better match the structure of the 'ant' script
 - insert the -Djikes.class.path in the right place (not as system property)
 - use 4 spaces instead of TAB indentation
 - assume ANT_HOME is the parent directory of the directory the script is in if 
the environment variable isn't set

This last change makes it possible to use runant.py on OpenVMS.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message