ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bode...@apache.org
Subject cvs commit: ant/xdocs antnews.xml bindownload.xml faq.xml index.xml srcdownload.xml
Date Wed, 13 Aug 2003 06:11:59 GMT
bodewig     2003/08/12 23:11:58

  Modified:    .        WHATSNEW
               docs     antnews.html bindownload.html faq.html index.html
                        srcdownload.html
               xdocs    antnews.xml bindownload.xml faq.xml index.xml
                        srcdownload.xml
  Log:
  Announce 1.5.4
  
  Revision  Changes    Path
  1.482     +40 -28    ant/WHATSNEW
  
  Index: WHATSNEW
  ===================================================================
  RCS file: /home/cvs/ant/WHATSNEW,v
  retrieving revision 1.481
  retrieving revision 1.482
  diff -u -r1.481 -r1.482
  --- WHATSNEW	5 Aug 2003 23:18:25 -0000	1.481
  +++ WHATSNEW	13 Aug 2003 06:11:58 -0000	1.482
  @@ -1,4 +1,4 @@
  -Changes from Ant 1.5.3 to current CVS version
  +Changes from Ant 1.5.4 to current CVS version
   =============================================
   
   Changes that could break older environments:
  @@ -30,10 +30,6 @@
     of the older ORO Netcomponents version.  See
     <http://jakarta.apache.org/commons/net/index.html>.
   
  -* If the Visual Age tasks used to work for you, they may stop doing so
  -  now - and we'd like to know about it.  The current set of tasks is
  -  supposed to work with any version of VAJ starting with 3.0.
  -
   * <input> will no longer prompt the user and wait for input if the
     addproperty attribute is set to a property that has already been
     defined in the project.  If you rely on the task waiting for input,
  @@ -153,18 +149,6 @@
   * Setting filesonly to true in <zip> and related tasks would cause the
     archives to be always recreated.  Bugzilla Report 19449.
   
  -* The Visual Age for Java tasks didn't work (at least for versions 3.0
  -  and higher).  Bugzilla Report 10016.
  -
  -* VAJImport task failed with NullPointerException when using DirectoryScanner.
  -  Bugzilla Report 22080.
  -
  -* URL-encoding in <vaj*port> didn't work properly.
  -
  -* VAJRemoteUtil called getAbsolutePath instead of getPath
  -  causing problems when using a Windows VAJ server from a UNIX server.
  -  Bugzilla Report 20457.
  -
   * file names that include spaces need to be quoted inside the @argfile
     argument using <javadoc> and JDK 1.4.  Bugzilla Report 16871.
   
  @@ -244,8 +228,6 @@
   * A new attribute named skip is added to the TailFilter and
     HeadFilter filter readers.
   
  -* Shipped XML parser is now Xerces 2.5.0
  -
   * The filesetmanifest attribute of <jar> has been reenabled.
   
   * The start and end tokens for <translate> may now be longer than a
  @@ -390,8 +372,6 @@
   * <sql> is able to display properly several resultsets if you are
     running a compound sql statement. Bugzilla Report 21594.
   
  -* <javah> will invoke oldjavah on JDK 1.4.2.  Bugzilla Report 18667.
  -
   * A new <containsregexp> selector has been added, that selects files
     if their content matches a certain regular expression.
   
  @@ -420,13 +400,6 @@
     control the automatic line-end conversion performed on ASCII files.
     Bugzilla Report 18884.
   
  -* The VAJ tasks now support a haltonfailure attribute to conditionally
  -  keep building even if they fail.
  -
  -* It is now possible to use the latest (versioned or unversioned) edition
  -  in <vajload> by using special wildcard characters.  Also fixes
  -  Bugzilla Report 2236.
  -
   * Users can now modify the list of default excludes using the new
     defaultexcludes task.  Bugzilla Report 12700.
   
  @@ -563,6 +536,45 @@
   * <zip> and friends have a new attribute "keepcompression" that can be
     used to incrementally build an archive mixing compressed and uncompressed
     entries.
  +
  +Changes from Ant 1.5.3 to Ant 1.5.4
  +===================================
  +
  +Changes that could break older environments:
  +--------------------------------------------
  +
  +* If the Visual Age tasks used to work for you, they may stop doing so
  +  now - and we'd like to know about it.  The current set of tasks is
  +  supposed to work with any version of VAJ starting with 3.0.
  +
  +Fixed bugs:
  +-----------
  +
  +* The Visual Age for Java tasks didn't work (at least for versions 3.0
  +  and higher).  Bugzilla Report 10016.
  +
  +* URL-encoding in <vaj*port> didn't work properly.
  +
  +* VAJRemoteUtil called getAbsolutePath instead of getPath
  +  causing problems when using a Windows VAJ server from a UNIX server.
  +  Bugzilla Report 20457.
  +
  +* VAJImport task failed with NullPointerException when using DirectoryScanner.
  +  Bugzilla Report 22080.
  +
  +Other changes:
  +--------------
  +
  +* Shipped XML parser is now Xerces 2.5.0
  +
  +* <javah> will invoke oldjavah on JDK 1.4.2.  Bugzilla Report 18667.
  +
  +* The VAJ tasks now support a haltonfailure attribute to conditionally
  +  keep building even if they fail.
  +
  +* It is now possible to use the latest (versioned or unversioned) edition
  +  in <vajload> by using special wildcard characters.  Also fixes
  +  Bugzilla Report 2236.
   
   Changes from Ant 1.5.2 to Ant 1.5.3
   ===================================
  
  
  
  1.76      +19 -7     ant/docs/antnews.html
  
  Index: antnews.html
  ===================================================================
  RCS file: /home/cvs/ant/docs/antnews.html,v
  retrieving revision 1.75
  retrieving revision 1.76
  diff -u -r1.75 -r1.76
  --- antnews.html	3 Jul 2003 08:37:17 -0000	1.75
  +++ antnews.html	13 Aug 2003 06:11:58 -0000	1.76
  @@ -171,6 +171,25 @@
     <div class="content">
       <h1 class="title">News</h1>
               <h3 class="section">
  +      <a name="Ant 1.5.4"></a>
  +      Ant 1.5.4
  +    </h3>
  +                        <h3>August 12, 2003 - Ant 1.5.4 Available</h3>
  +                                <p>Apache Ant 1.5.4 is now available for 
  +     <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
  +    </p>
  +                                <p>This is a minor bugfix release that fixes a problem
with the
  +    <code>javah</code> task on JDK 1.4.2 and a couple of bugs in the
  +    Visual Age for Java intergration tasks.  If you don't use javah or
  +    VAJ, there is no reason to upgrade.</p>
  +                                <div class="warning">
  +    <div class="label">Note</div>
  +    <div class="content">Ant 1.5.4 will be the last release that supports
  +      JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
  +      later.
  +    </div>
  +    </div>
  +                        <h3 class="section">
         <a name="Java Pro 2003 Readers Choice Award"></a>
         Java Pro 2003 Readers Choice Award
       </h3>
  @@ -213,13 +232,6 @@
                                   <p>Apache Ant 1.5.3 is now available for 
        <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
       </p>
  -                                <div class="warning">
  -    <div class="label">Note</div>
  -    <div class="content">Ant 1.5.3 will be the last release that supports
  -      JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
  -      later
  -    </div>
  -    </div>
                           <h3 class="section">
         <a name="Ant 1.5.3 Beta 1"></a>
         Ant 1.5.3 Beta 1
  
  
  
  1.35      +15 -17    ant/docs/bindownload.html
  
  Index: bindownload.html
  ===================================================================
  RCS file: /home/cvs/ant/docs/bindownload.html,v
  retrieving revision 1.34
  retrieving revision 1.35
  diff -u -r1.34 -r1.35
  --- bindownload.html	3 Jul 2003 08:37:17 -0000	1.34
  +++ bindownload.html	13 Aug 2003 06:11:58 -0000	1.35
  @@ -212,30 +212,28 @@
         <a name="Current Release of Ant"></a>
         Current Release of Ant
       </h3>
  -                        <p>Currently, Apache Ant 1.5.3 is the best available version,
see the
  +                        <p>Currently, Apache Ant 1.5.4 is the best available version,
see the
   <a href="[preferred]/ant/README.html">release notes</a>.</p>
                                   <div class="warning">
   <div class="label">Note</div>
  -<div class="content">An updated version of Ant 1.5.3 has been released on 17-April-2003
and may not be available on all 
  -mirrors for a few days. This updated version, apache-ant-1.5.3-1, is identical to the original
1.5.3 build apart from 
  -the removal of a spurious junit.jar file. 
  -</div>
  +<div class="content">Ant 1.5.4 has been released on 12-August-2003 and
  +may not be available on all mirrors for a few days.</div>
   </div>
                                   <ul>
   <li><code>.zip</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.zip">apache-ant-1.5.3-1-bin.zip</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.zip.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.zip.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.zip">apache-ant-1.5.4-bin.zip</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.zip.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.zip.md5">MD5</a>]</li>
   
   <li><code>.tar.gz</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz">apache-ant-1.5.3-1-bin.tar.gz</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.tar.gz">apache-ant-1.5.4-bin.tar.gz</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.gz.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.gz.md5">MD5</a>]</li>
   
   <li><code>.tar.bz2</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2">apache-ant-1.5.3-1-bin.tar.bz2</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.tar.bz2">apache-ant-1.5.4-bin.tar.bz2</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.bz2.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.bz2.md5">MD5</a>]</li>
   </ul>
                           <h3 class="section">
         <a name="Nightly Builds"></a>
  @@ -266,17 +264,17 @@
   using</p>
                                   <p><code>
   % pgpk -a KEYS<br />
  -% pgpv apache-ant-1.5.3-1-bin.tar.gz.asc<br />
  +% pgpv apache-ant-1.5.4-bin.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % pgp -ka KEYS<br />
  -% pgp apache-ant-1.5.3-1-bin.tar.gz.asc<br />
  +% pgp apache-ant-1.5.4-bin.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % gpg --import KEYS<br />
  -% gpg --verify apache-ant-1.5.3-1-bin.tar.gz.asc
  +% gpg --verify apache-ant-1.5.4-bin.tar.gz.asc
   </code></p>
                                   <p>Alternatively, you can verify the MD5 signature
on the files.  A
   unix program called <code>md5</code> or <code>md5sum</code> is
  
  
  
  1.75      +10 -0     ant/docs/faq.html
  
  Index: faq.html
  ===================================================================
  RCS file: /home/cvs/ant/docs/faq.html,v
  retrieving revision 1.74
  retrieving revision 1.75
  diff -u -r1.74 -r1.75
  --- faq.html	3 Jul 2003 08:37:17 -0000	1.74
  +++ faq.html	13 Aug 2003 06:11:58 -0000	1.75
  @@ -509,6 +509,16 @@
             9 April 2003
         </td>
         </tr>
  +                  <tr>
  +                      <td colspan="1" rowspan="1"
  +      valign="top" align="left">
  +          1.5.4
  +      </td>
  +                          <td colspan="1" rowspan="1"
  +      valign="top" align="left">
  +          12 August 2003
  +      </td>
  +      </tr>
           </table>
                                   <p class="faq">
         <a name="no-gnu-tar"></a>
  
  
  
  1.285     +4 -4      ant/docs/index.html
  
  Index: index.html
  ===================================================================
  RCS file: /home/cvs/ant/docs/index.html,v
  retrieving revision 1.284
  retrieving revision 1.285
  diff -u -r1.284 -r1.285
  --- index.html	3 Jul 2003 08:37:17 -0000	1.284
  +++ index.html	13 Aug 2003 06:11:58 -0000	1.285
  @@ -183,15 +183,15 @@
             <strong>Most Valuable Java Deployment Technology</strong>
       </p>
                           <h3 class="section">
  -      <a name="Ant 1.5.3"></a>
  -      Ant 1.5.3
  +      <a name="Ant 1.5.4"></a>
  +      Ant 1.5.4
       </h3>
  -                        <p>Apache Ant 1.5.3 is now available for 
  +                        <p>Apache Ant 1.5.4 is now available for 
        <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
       </p>
                                   <div class="warning">
       <div class="label">Note</div>
  -    <div class="content">Ant 1.5.3 will be the last release that supports
  +    <div class="content">Ant 1.5.4 will be the last release that supports
         JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
         later
       </div>
  
  
  
  1.34      +15 -17    ant/docs/srcdownload.html
  
  Index: srcdownload.html
  ===================================================================
  RCS file: /home/cvs/ant/docs/srcdownload.html,v
  retrieving revision 1.33
  retrieving revision 1.34
  diff -u -r1.33 -r1.34
  --- srcdownload.html	3 Jul 2003 08:37:18 -0000	1.33
  +++ srcdownload.html	13 Aug 2003 06:11:58 -0000	1.34
  @@ -210,30 +210,28 @@
         <a name="Current Release of Ant"></a>
         Current Release of Ant
       </h3>
  -                        <p>Currently, Apache Ant 1.5.3 is the best available version,
see the
  +                        <p>Currently, Apache Ant 1.5.4 is the best available version,
see the
   <a href="[preferred]/ant/README.html">release notes</a>.</p>
                                   <div class="warning">
   <div class="label">Note</div>
  -<div class="content">An updated version of Ant 1.5.3 has been released on 17-April-2003
and may not be available on all 
  -mirrors for a few days. This updated version, apache-ant-1.5.3-1, is identical to the original
1.5.3 build apart from 
  -the removal of a spurious junit.jar file. 
  -</div>
  +<div class="content">Ant 1.5.4 has been released on 12-August-2003 and
  +may not be available on all mirrors for a few days.</div>
   </div>
                                   <ul>
   <li><code>.zip</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.zip">apache-ant-1.5.3-1-src.zip</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.zip.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.zip.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.zip">apache-ant-1.5.4-src.zip</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.zip.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.zip.md5">MD5</a>]</li>
   
   <li><code>.tar.gz</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.tar.gz">apache-ant-1.5.3-1-src.tar.gz</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.gz.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.gz.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.tar.gz">apache-ant-1.5.4-src.tar.gz</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.gz.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.gz.md5">MD5</a>]</li>
   
   <li><code>.tar.bz2</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.tar.bz2">apache-ant-1.5.3-1-src.tar.bz2</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.bz2.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.bz2.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.tar.bz2">apache-ant-1.5.4-src.tar.bz2</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.bz2.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.bz2.md5">MD5</a>]</li>
   </ul>
                           <h3 class="section">
         <a name="Nightly Builds"></a>
  @@ -264,17 +262,17 @@
   using</p>
                                   <p><code>
   % pgpk -a KEYS<br />
  -% pgpv apache-ant-1.5.3-1-src.tar.gz.asc<br />
  +% pgpv apache-ant-1.5.4-src.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % pgp -ka KEYS<br />
  -% pgp apache-ant-1.5.3-1-src.tar.gz.asc<br />
  +% pgp apache-ant-1.5.4-src.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % gpg --import KEYS<br />
  -% gpg --verify apache-ant-1.5.3-1-src.tar.gz.asc
  +% gpg --verify apache-ant-1.5.4-src.tar.gz.asc
   </code></p>
                                   <p>Alternatively, you can verify the MD5 signature
on the files.  A
   unix program called <code>md5</code> or <code>md5sum</code> is
  
  
  
  1.47      +20 -9     ant/xdocs/antnews.xml
  
  Index: antnews.xml
  ===================================================================
  RCS file: /home/cvs/ant/xdocs/antnews.xml,v
  retrieving revision 1.46
  retrieving revision 1.47
  diff -u -r1.46 -r1.47
  --- antnews.xml	2 Jul 2003 13:55:03 -0000	1.46
  +++ antnews.xml	13 Aug 2003 06:11:58 -0000	1.47
  @@ -9,6 +9,26 @@
     </properties>
   
   <body>
  +  <section name="Ant 1.5.4">
  +    <h3>August 12, 2003 - Ant 1.5.4 Available</h3>
  +    <p>Apache Ant 1.5.4 is now available for 
  +     <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
  +    </p>
  +    
  +    <p>This is a minor bugfix release that fixes a problem with the
  +    <code>javah</code> task on JDK 1.4.2 and a couple of bugs in the
  +    Visual Age for Java intergration tasks.  If you don't use javah or
  +    VAJ, there is no reason to upgrade.</p>
  +
  +    <div class="warning">
  +    <div class="label">Note</div>
  +    <div class="content">Ant 1.5.4 will be the last release that supports
  +      JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
  +      later.
  +    </div>
  +    </div>
  +  </section>
  +
     <section name="Java Pro 2003 Readers Choice Award">
       <a href="http://www.ftponline.com/javapro/">
         <img style="padding: 5px" src="images/jp_rcwinner_2003.gif" alt="" border="0"
height="80" width="139" align="right"/></a>
  @@ -50,15 +70,6 @@
       <p>Apache Ant 1.5.3 is now available for 
        <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
       </p>
  -    
  -    <div class="warning">
  -    <div class="label">Note</div>
  -    <div class="content">Ant 1.5.3 will be the last release that supports
  -      JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
  -      later
  -    </div>
  -    </div>
  -    
     </section>
   
   
  
  
  
  1.16      +15 -17    ant/xdocs/bindownload.xml
  
  Index: bindownload.xml
  ===================================================================
  RCS file: /home/cvs/ant/xdocs/bindownload.xml,v
  retrieving revision 1.15
  retrieving revision 1.16
  diff -u -r1.15 -r1.16
  --- bindownload.xml	25 Apr 2003 13:17:26 -0000	1.15
  +++ bindownload.xml	13 Aug 2003 06:11:58 -0000	1.16
  @@ -59,32 +59,30 @@
   
   <section name="Current Release of Ant">
   
  -<p>Currently, Apache Ant 1.5.3 is the best available version, see the
  +<p>Currently, Apache Ant 1.5.4 is the best available version, see the
   <a href="[preferred]/ant/README.html">release notes</a>.</p>
   
   <div class="warning">
   <div class="label">Note</div>
  -<div class="content">An updated version of Ant 1.5.3 has been released on 17-April-2003
and may not be available on all 
  -mirrors for a few days. This updated version, apache-ant-1.5.3-1, is identical to the original
1.5.3 build apart from 
  -the removal of a spurious junit.jar file. 
  -</div>
  +<div class="content">Ant 1.5.4 has been released on 12-August-2003 and
  +may not be available on all mirrors for a few days.</div>
   </div>
   
   <ul>
   <li><code>.zip</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.zip">apache-ant-1.5.3-1-bin.zip</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.zip.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.zip.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.zip">apache-ant-1.5.4-bin.zip</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.zip.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.zip.md5">MD5</a>]</li>
   
   <li><code>.tar.gz</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz">apache-ant-1.5.3-1-bin.tar.gz</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.gz.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.tar.gz">apache-ant-1.5.4-bin.tar.gz</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.gz.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.gz.md5">MD5</a>]</li>
   
   <li><code>.tar.bz2</code> archive: 
  -<a href="[preferred]/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2">apache-ant-1.5.3-1-bin.tar.bz2</a>

  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.3-1-bin.tar.bz2.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/binaries/apache-ant-1.5.4-bin.tar.bz2">apache-ant-1.5.4-bin.tar.bz2</a>

  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.bz2.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/binaries/apache-ant-1.5.4-bin.tar.bz2.md5">MD5</a>]</li>
   </ul>
   </section>
   
  @@ -122,17 +120,17 @@
   
   <p><code>
   % pgpk -a KEYS<br />
  -% pgpv apache-ant-1.5.3-1-bin.tar.gz.asc<br />
  +% pgpv apache-ant-1.5.4-bin.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % pgp -ka KEYS<br />
  -% pgp apache-ant-1.5.3-1-bin.tar.gz.asc<br />
  +% pgp apache-ant-1.5.4-bin.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % gpg --import KEYS<br />
  -% gpg --verify apache-ant-1.5.3-1-bin.tar.gz.asc
  +% gpg --verify apache-ant-1.5.4-bin.tar.gz.asc
   </code></p>
   
   <p>Alternatively, you can verify the MD5 signature on the files.  A
  
  
  
  1.36      +5 -0      ant/xdocs/faq.xml
  
  Index: faq.xml
  ===================================================================
  RCS file: /home/cvs/ant/xdocs/faq.xml,v
  retrieving revision 1.35
  retrieving revision 1.36
  diff -u -r1.35 -r1.36
  --- faq.xml	14 Apr 2003 19:28:14 -0000	1.35
  +++ faq.xml	13 Aug 2003 06:11:58 -0000	1.36
  @@ -161,6 +161,11 @@
               <td>1.5.3</td>
               <td>9 April 2003</td>
             </tr>
  +
  +          <tr>
  +            <td>1.5.4</td>
  +            <td>12 August 2003</td>
  +          </tr>
           </table>
         </answer>
       </faq>
  
  
  
  1.50      +4 -4      ant/xdocs/index.xml
  
  Index: index.xml
  ===================================================================
  RCS file: /home/cvs/ant/xdocs/index.xml,v
  retrieving revision 1.49
  retrieving revision 1.50
  diff -u -r1.49 -r1.50
  --- index.xml	2 Jul 2003 13:55:04 -0000	1.49
  +++ index.xml	13 Aug 2003 06:11:58 -0000	1.50
  @@ -24,21 +24,21 @@
       </p>
   </section>
       
  - <section name="Ant 1.5.3">
  -    <p>Apache Ant 1.5.3 is now available for 
  + <section name="Ant 1.5.4">
  +    <p>Apache Ant 1.5.4 is now available for 
        <a href="http://ant.apache.org/bindownload.cgi">download</a>. 
       </p>
       
       <div class="warning">
       <div class="label">Note</div>
  -    <div class="content">Ant 1.5.3 will be the last release that supports
  +    <div class="content">Ant 1.5.4 will be the last release that supports
         JDK 1.1. The next major release of Ant, Ant 1.6, will require JDK 1.2 or
         later
       </div>
       </div>
       
     </section>
  -  
  +
     <section name="Apache Ant">
   
   <p>
  
  
  
  1.14      +15 -17    ant/xdocs/srcdownload.xml
  
  Index: srcdownload.xml
  ===================================================================
  RCS file: /home/cvs/ant/xdocs/srcdownload.xml,v
  retrieving revision 1.13
  retrieving revision 1.14
  diff -u -r1.13 -r1.14
  --- srcdownload.xml	25 Apr 2003 13:17:26 -0000	1.13
  +++ srcdownload.xml	13 Aug 2003 06:11:58 -0000	1.14
  @@ -56,32 +56,30 @@
   
   <section name="Current Release of Ant">
   
  -<p>Currently, Apache Ant 1.5.3 is the best available version, see the
  +<p>Currently, Apache Ant 1.5.4 is the best available version, see the
   <a href="[preferred]/ant/README.html">release notes</a>.</p>
   
   <div class="warning">
   <div class="label">Note</div>
  -<div class="content">An updated version of Ant 1.5.3 has been released on 17-April-2003
and may not be available on all 
  -mirrors for a few days. This updated version, apache-ant-1.5.3-1, is identical to the original
1.5.3 build apart from 
  -the removal of a spurious junit.jar file. 
  -</div>
  +<div class="content">Ant 1.5.4 has been released on 12-August-2003 and
  +may not be available on all mirrors for a few days.</div>
   </div>
   
   <ul>
   <li><code>.zip</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.zip">apache-ant-1.5.3-1-src.zip</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.zip.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.zip.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.zip">apache-ant-1.5.4-src.zip</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.zip.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.zip.md5">MD5</a>]</li>
   
   <li><code>.tar.gz</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.tar.gz">apache-ant-1.5.3-1-src.tar.gz</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.gz.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.gz.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.tar.gz">apache-ant-1.5.4-src.tar.gz</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.gz.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.gz.md5">MD5</a>]</li>
   
   <li><code>.tar.bz2</code> archive: 
  -<a href="[preferred]/ant/source/apache-ant-1.5.3-1-src.tar.bz2">apache-ant-1.5.3-1-src.tar.bz2</a>

  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.bz2.asc">PGP</a>]
  -[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.3-1-src.tar.bz2.md5">MD5</a>]</li>
  +<a href="[preferred]/ant/source/apache-ant-1.5.4-src.tar.bz2">apache-ant-1.5.4-src.tar.bz2</a>

  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.bz2.asc">PGP</a>]
  +[<a href="http://www.apache.org/dist/ant/source/apache-ant-1.5.4-src.tar.bz2.md5">MD5</a>]</li>
   </ul>
   </section>
   
  @@ -119,17 +117,17 @@
   
   <p><code>
   % pgpk -a KEYS<br />
  -% pgpv apache-ant-1.5.3-1-src.tar.gz.asc<br />
  +% pgpv apache-ant-1.5.4-src.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % pgp -ka KEYS<br />
  -% pgp apache-ant-1.5.3-1-src.tar.gz.asc<br />
  +% pgp apache-ant-1.5.4-src.tar.gz.asc<br />
   </code>
   <em>or</em><br />
   <code>
   % gpg --import KEYS<br />
  -% gpg --verify apache-ant-1.5.3-1-src.tar.gz.asc
  +% gpg --verify apache-ant-1.5.4-src.tar.gz.asc
   </code></p>
   
   <p>Alternatively, you can verify the MD5 signature on the files.  A
  
  
  

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message