ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22326] - remove deprecated / 1.1 issues packages ant and ant.filters - ant.loader
Date Tue, 12 Aug 2003 19:44:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22326>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22326

remove deprecated / 1.1 issues packages ant and ant.filters - ant.loader





------- Additional Comments From ant@kruithof.xs4all.nl  2003-08-12 19:44 -------
Currently I am also looking at packages types  - zip, and I think about marking
some methods and classes deprecated for their only purpose is to work around 1.1
- 1.2 differences, is this ok?

Further I would like to bring up the question if it is really good to introduce
WeakishReference in 1.6 (at least according to the @since tags in the code). As
1.6 need not compile against 1.1 and the only purpose of this class (and
WeakishReference12 is to work around a 1.1 / 1.2 difference. (I would definetely
have marked it deprecated if it is ok to mark them deprecated, but it seems a
bit silly to introduce a new class in a new release that is deprecated from the
start.)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message