ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From matt.sm...@tekelec.com
Subject Re: problems with import task
Date Tue, 15 Jul 2003 17:16:04 GMT

I agree.  I had implemented an import task for 1.5.3 that processed a build
file and ignored the project tag on the imported file.  I messed with the
1.6 import and found it difficult at best to maintain supportability in the
build files.  The import I had implemented basically added the targets,
properties and references from the import to the current project in place.
My build structure is now pretty common with a thin layer of build files in
each project.  Nested imports are supported and I have been using this for
months now without issues.  It worked out well, as now I even have imports
that are defining my third party dependencies and they are nested so that
when I deploy a project, even though it has no direct knowledge of third
party dependencies, ALL necessary jars, tlds, dtds, etc. are deployed.

I can post the task and sample build file if you'd like...

m.


                                                                                         
                                                  
                    Erik Hatcher                                                         
                                                  
                    <jakarta-ant@ehatchersolu        To:     ant-dev <dev@ant.apache.org>
                                                  
                    tions.com>                       cc:                              
                                                     
                                                     Subject:     problems with import task
                                                
                    07/15/2003 11:30 AM                                                  
                                                  
                    Please respond to "Ant                                               
                                                  
                    Developers List"                                                     
                                                  
                                                                                         
                                                  
                                                                                         
                                                  




I'm finally getting around to trying the latest features of CVS Ant in
a production environment.  The <import> task will help tremendously, no
question, but I've run into a couple of issues:

- I tried doing to <import>'s in the same build file, and the second
import failed because it could not find the file, although it appears
the relative base directory is being mangled after the first import.
Or am I confused and missing something here?

- Having the stuff imported *after* all the top-level items really is
making things tough.  I've had to move some top-level stuff specific to
my concrete project into an init target since it relies on properties
set from the imported build file.  I'm guessing this is hard to fix
though?

I haven't had time to dig deeper into these issues, but I wanted to
toss them out there in case someone else is eager to jump on it.

           Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message