ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 22010] - ENTITY SYSTEM include files pits %20 in file then does not work.
Date Thu, 31 Jul 2003 13:19:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22010>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=22010

ENTITY SYSTEM include files pits %20 in file then does not work.

antoine@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME



------- Additional Comments From antoine@apache.org  2003-07-31 13:19 -------
I have tested this with :

entity.xml

<?xml version="1.0"?>
<!DOCTYPE project [
    <!ENTITY common SYSTEM "C:/Program%20Files/common.xml">
]>
<project name="test" default="test" basedir=".">
  <target name="setup">
    <echo message="we are in setup"/>
  </target>
  &common;
</project>

common.xml under C:/Program Files/

<target name="test" depends="setup">
<echo message="we are in common.xml"/>
</target>



This works for me using ant1.6alpha.

This works also using ant1.5.3.1, however with a warning message saying :
C:\Program%20Files\common.xml could not be found

Whether I use %20 or a space does not make a difference in both cases.

Is it possible that you have an old version of xerces.jar in your CLASSPATH ?

Try to unset your CLASSPATH and rerun your build to see if it goes better.

Antoine

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message