ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@antbuild.com>
Subject Re: ant 1.5.4 : Import
Date Thu, 31 Jul 2003 12:38:37 GMT

I am willing to start changing <import> based on the email of Conor of July
29th, 2003.
I am of course more than happy if other committers want to participate in
the exercise.

> In fact I would like to rename <import> as <include> to reinforce the fact
> that this is its primary function. In fact the problems we are seeing with
> import all come because it tries to do two things beyond a simple #include
> operation - target renaming and allowing imports to access resources
> according to their import file location.
>

Do we want to do this renaming of <import> into <include> ?
>
> 1. import with optional name. The name is to be used in the renaming of
> targets.
>
ProjectHelper2#onStartElement seems to be the place where this happens.

> 2. Define a single property ant.import.file which is resolved at import
time
> to the import location. All other properties are nt resolved.
>
there is already an ant.file.[project_name] which gets generated in
ProjectHelper2 if I understand correctly. Do we want to change the name of
this property ?

> 3. All containers are <project>s for IDE compatibility. Note, however,
that
> there will be some build files, designed to be imported, which will not be
> valid standal;ong build files - e.g. their targets may depend on
non-existent
> targets which the importer is to provide.

OK
>
> 4. All normal Ant operations (i.e. not imports) are resolved to the
basedir of
> the outer project. There is no access to other basedirs.
>
Does this imply changing some existing code ?

> 5. Import specs are relative to importing file location. Don't use href as
it
> creates expectations of a URL which opens up issues.
>
This is already the case. Fine.

> 6. An attribute may be added to the <project> element to mark a build file
as
> not importable.
>
Does not seem difficult. importable would be the name of the new attribute.

> Keep it Simple.
>
Fully agreed.

Antoine



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message