ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13847] - pvcs task: wrong option (-r) specified for get (should be -v)
Date Wed, 11 Jun 2003 13:03:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13847>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13847

pvcs task: wrong option (-r) specified for get (should be -v)





------- Additional Comments From joerg.buchberger@pruftechnik-rv.com  2003-06-11 13:03 -------
You can solve it, without breaking backward compatibility.

1. you need two new optional attributes:
revision - only files marked with this revision are extracted (using "-r"-option) 
backwardcompatible - default yes; if set to no ... (see description below) 

2. you need to adapt the version attribute:
- by default it will behave as before (using "-r"-option)
- if the "backwardcompatible"-attribute is set to no=false=off the version
attributes' value will be really interpreted as version-label, i.e. using the
"-v"-option

(Alternatively you might consider using a numeric value instead of a boolean for
such backward-compatibility workarounds. This would enable you not only to
discern between two incompatible development-states of a given task. But this
would get way more complicated, i.e. I wouldn't really consider it an option
unless there evolves a concept to handle this for ant as a whole. And even then
this alternative still seems overly complicated and dangerous if thought thru.)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message