ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Loïc Péron <loic.pe...@bigfoot.com>
Subject [embed] [patch] embed-head does not work with ant 1.5.3
Date Thu, 10 Apr 2003 13:06:36 GMT
Hi,

embed currently does not work with ant-1.5.3

1) RuntimeConfigurable2 does not compile because it uses a method
   introduced for 1.6:
       ih = IntrospectionHelper.getHelper(Project p, Class c);
   which can easily be replaced by:
       ih = IntrospectionHelper.getHelper(Class c);
       p.addBuildListener(ih);

2) PropertyHelper needs to be passed the properties set in the
   project to correctly replace them because it does not get these
   itself anymore in 1.6:
       ph.replaceProperties(null, value, null);
   must be replaced by:
       ph.replaceProperties(null, value, p.getProperties());

Costin, may you please apply the attached patch which contains these
changes and allows embed-head to compile and run with ant-1.5.3

PropertyHelper could also be synchronized with 1.6 to get a few
corrections.

Thanks all for your hard work.

-- 
Loïc Péron

phone:(33) 683 880 177
mailto:loic.peron@bigfoot.com
Mime
View raw message