ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [VOTE] JDK 1.1 support
Date Thu, 20 Mar 2003 07:25:40 GMT
On Wed, 19 Mar 2003, Dominique Devienne <DDevienne@lgc.com> wrote:

> From what I gathered, JDK 1.1 support is already broken in a few
> places in Ant 1.5.x,

In 1.5.2, yes.  Whether the binary releases of 1.5 and 1.5.1 really
don't work on JDK 1.1 has to be verified (on my TODO list for today).

> Leaving JDK 1.1 behind should also mean forking the 1.6 code from
> the 1.5 code.

It already is (CVS calls these forks branches 8-).

> I don't see reasons to try to back-port fixes made on 1.6 to the
> 1.5.

Uh?

If there is a serious bug in 1.5.3 (like not detecting Windows 2007 on
JDK 2.9) long before we are ready to release Ant 1.6, I think we
should backport the fix to the 1.5 branch and do yet another 1.5.x
release.

Stefan

Mime
View raw message