ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: java 1.1 on linux
Date Thu, 20 Mar 2003 15:54:50 GMT
On Tue, 18 Mar 2003, peter reilly <peter.reilly@corvil.com> wrote:

> 1.5.1 and 1.5: java.lang.ClassFormatError: Bad major version number

I do not get this on an admittedly simple build file using Blackdown's
1.1.8.  I.e. Ant 1.5.1 from the binary tar.gz version seems to work
with JDK 1.1 for me.

>      This may be fixed by recompiling ant or it may be due to the
>      fact that ant-contrib uses 1.2 isms.

Does that mean I should use one of the ant-contrib tasks to reproduce
the problem?  Maybe the ant-contrib stuff has been compiled with JDK
1.4.  Where have you obtained it (self-compiled?)?

Stefan

Mime
View raw message