ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: JDK 1.1 support
Date Fri, 14 Mar 2003 15:41:45 GMT
Stefan Bodewig wrote:

> Fine with me.
> 
> I'd like to keep 1.6 compatible to JDK 1.1, though.  When we make 1.2
> a requirement, we'd better start using collections and URLClassloader
> consistently - and doing this for 1.6 would push 1.6 even further down
> the timeline.

There are 3 issues:
1. Supporting JDK1.1 - that takes pain and effort and introduces ugly 
constructs. Droping support for 1.1 ( since almost nobody is actually
supporting it or using it ) will reduce the timeline.

2. Using URLClassload imediately will simplify a lot of code and
probably make ant more stable. 

3. A full scale transition to 1.2 - i.e. using collections everywhere, etc -
is not required and we can do it gradually, during the next 2-3 releases.
Use JDK1.2 where it makes sense and simplifies things ( like removing the
introspections that are hard to maintain ), but we don't need to make
gratuituous changes.


>> Just as a data point, CVS HEAD (Ant 1.6) has not compiled against
>> JDK 1.1 for a while now (due to diagnostics changes).
> 
> But I've nagged Steve about it and promise to fix it during the next
> few weeks. 8-)

Wouldn't you rather fix other things :-) ?
Most likely a "fix" will be more introspection magic...

Costin


Mime
View raw message