ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18513] New: - Weblogic deployment does not work properly
Date Mon, 31 Mar 2003 12:00:26 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18513>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18513

Weblogic deployment does not work properly

           Summary: Weblogic deployment does not work properly
           Product: Ant
           Version: 1.5.2
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Other
        AssignedTo: dev@ant.apache.org
        ReportedBy: yewloon_wong@sg.firstapex.com


Hi

I am trying to deploy my application through ANT scripts, but I am always 
getting error saying the component does not exist in the application. When I 
deploy it manually, the same EAR file I manually deploy through the Weblogic 
console, the deployment works fine. Any clue on this ?

Yew Loon


     <serverdeploy action="deploy" source="${shipment_dir}/${ear_file}">
        <weblogic application="${application}"
            server="${webserver_console}"
            classpath="${weblogic_home}/lib/weblogic.jar"
            component="GenieEJB:${webserver}"
            username="${username}"
            password="${password}"/>
     </serverdeploy>

ERRORs
======

D:\xgenv4>ant -f weblogic_deploy.xml
Buildfile: weblogic_deploy.xml

deploy_ear:
     [java] weblogic.j2ee.DeploymentException: Application MarketingUW does not
contain component GenieEJB
     [java]     at weblogic.deploy.deploy(deploy.java:674)
     [java]     at weblogic.deploy.runBody(deploy.java:360)
     [java]     at weblogic.utils.compiler.Tool.run(Tool.java:126)
     [java]     at weblogic.deploy.main(deploy.java:1641)


     [java] Application MarketingUW does not contain component GenieEJB

BUILD FAILED
file:D:/xgenv4/weblogic_deploy.xml:33: Java returned: 1

Total time: 54 seconds

Mime
View raw message