ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16934] - BuildNumber task does not set property correctly
Date Mon, 31 Mar 2003 06:17:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16934>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16934

BuildNumber task does not set property correctly

conor@cortexebusiness.com.au changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |INVALID



------- Additional Comments From conor@cortexebusiness.com.au  2003-03-31 06:17 -------
This is by design. From the docs

It will first attempt to read a build number from a file (by default,
build.number in the current directory), then set the property build.number to
the value that was read in (or to 0, if no such value). It will then increment
the number by one and write it back out to the file.

So, the contents of the file will always be one ahead of the property in the build.

To achieve the result you want, try this instead.

      <propertyfile file="ae.version">
        <entry key="build.number" type="int" operation="+" value="1"/>
      </propertyfile>
      <property file="ae.version"/>

Mime
View raw message