ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18267] New: - ejbjar does not work with WebSphere 5
Date Mon, 24 Mar 2003 06:51:38 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18267>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18267

ejbjar does not work with WebSphere 5

           Summary: ejbjar does not work with WebSphere 5
           Product: Ant
           Version: 1.5.2
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: rlewisshell@mac.com


The websphere nested element of ejbjar does not appear to work with WebSphere 
5.  (If it does in fact work, it does not work as advertised in the docs, in 
which case, this becomes a documentation bug)

The reason appears to be because the v5 ejbdeploy tool requires ws.ext.dirs to 
be set (to most of what was previously set in the <wasclasspath> element).  I 
have modified WebsphereDeploymentTool to verify this (ie. allow setting 
ws.ext.dirs in the nested element), and it works.  Am willing/hoping to share 
the code ... but not sure how.

Mime
View raw message