ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conor MacNeill <co...@cortexebusiness.com.au>
Subject Re: Some library questions for the optional.jar stuff
Date Fri, 21 Mar 2003 14:40:41 GMT
On Sat, 22 Mar 2003 01:28 am, Stefan Bodewig wrote:
> Unless I'm mistaken, it seems that I'll have to compile a complete
> optional.jar for next Monday. 8-)
>

Ah cool - I thought it might be me :-). I'm working on the ManifestEncoding 
changes. I wouldn't mind having an example manifest in a different charset

> OK, I've just now tried with an oldish fakeall.jar by Jon Skeet and
> the goodies Gump puts onto my box and ran into the following problems:
>
>     [javac] DDCreatorHelper.java:60: package javax.ejb.deployment does not
> exist [javac] import javax.ejb.deployment.DeploymentDescriptor;
>
> I do have ejb.jar from "ejb-2_0-fr-class.zip, i.e. what you get when
> you click on 2.0 Final Release "Download Class Files", it doesn't seem
> to contain the above package.  Do I need 2.1 final draft?  Something
> else?

You are more likely to need ejb 1.0 :-) 

We really need to have some way of marking tasks as obsolete. I don't know if 
anyone is using this task anymore because the app servers it supports are so 
old and end-of-life'd.

I'm tempted to suggest that we don't bother building these and just include in 
the source distribution this time around. Thereafter we need a "legacy task" 
area where these can live and be distributed without being built for ongoing 
distrbutions.

Thoughts?

Conor


-- 
Conor MacNeill
Blog: http://codefeed.com/blog/

Mime
View raw message