ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18151] New: - java.lang.NoClassDefFoundError: hello/HelloClient jaxrpc sample
Date Wed, 19 Mar 2003 16:36:31 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18151>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18151

java.lang.NoClassDefFoundError: hello/HelloClient jaxrpc sample

           Summary: java.lang.NoClassDefFoundError: hello/HelloClient jaxrpc
                    sample
           Product: Ant
           Version: 1.5.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Other
        AssignedTo: dev@ant.apache.org
        ReportedBy: lorenzale@lorenzale.it


Exception in thread 'main' due to java.lang.NoClassDefFoundError: 
hello/HelloClient while trying to connect to the HelloWorldService configured 
in TOMCAT container. The preceeding compilations and service deployment of all 
that concerns this jaxrpc example (HelloWorld) included in JWSDP-1.1 package 
went to positive conclusion. The message that comes out as I try 'ant run' is 
like this:
> ant -v run

C:\Documents and Settings\administrator\jwsdp-1.1
\docs\tutorial\examples\jaxrpc\hello>ant -v run 
Apache Ant version 1.5.2 compiled on February 28 2003
Buildfile: build.xml
Detected Java version: 1.4 in: C:\JBuilder8\jdk1.4\jre
Detected OS: Windows 2000
parsing buildfile build.xml with URI = file:C:/Documents and 
Settings/administrator/jwsdp-1.1/docs/tutorial/examples/jaxrpc/hello/build.xml
Project base dir set to: C:\Documents and Settings\administrator\jwsdp-1.1
\docs\tutorial\examples\jaxrpc\hello
[property] Loading C:\Documents and Settings\administrator\build.properties
[property] Loading C:\Documents and Settings\administrator\jwsdp-1.1
\docs\tutorial\examples\jaxrpc\common\build.properties
[property] Loading C:\Documents and Settings\administrator\jwsdp-1.1
\docs\tutorial\examples\jaxrpc\hello\build.properties
resolving systemId: file:../common/targets.xml
Build sequence for target `run' is [run]
Complete build sequence is [run, clean-client, undeploy, prepare, set-ws-
scripts, process-war, clean-wars, deploy, package, compile-client, start, 
clean, compile-server, setup-web-inf, build-service, jar-client, build-dynamic, 
redeploy, build, generate-stubs, build-static, stop, show-props, list]

run:
[echo] Running the hello.HelloClient program....
[java] Executing 'C:\JBuilder8\jdk1.4\jre\bin\java.exe' with arguments:
[java] '-classpath'
[java] 'C:\Documents and Settings\administrator\jwsdp-1.1
\docs\tutorial\examples\jaxrpc\hello\dist\hello-client.jar;C:\Documents and 
Settings\Administrator\jwsdp-1.1\jaxrpc-1.0.3\lib\jaxrpc-api.jar;C:\Documents 
and Settings\Administrator\jwsdp-1.1\jaxrpc-1.0.3\lib\jaxrpc-
ri.jar;C:\Documents and Settings\Administrator\jwsdp-1.1\jaxp-1.2.2\lib\jaxp-
api.jar;C:\Documents and Settings\Administrator\jwsdp-1.1\jaxp-1.2.2
\lib\endorsed\xercesImpl.jar;C:\Documents and Settings\Administrator\jwsdp-1.1
\jaxp-1.2.2\lib\endorsed\xalan.jar;C:\Documents and 
Settings\Administrator\jwsdp-1.1\jaxp-1.2.2\lib\endorsed\xsltc.jar;C:\Documents 
and Settings\Administrator\jwsdp-1.1\jaxp-1.2.2
\lib\endorsed\dom.jar;C:\Documents and Settings\Administrator\jwsdp-1.1\jaxp-
1.2.2\lib\endorsed\sax.jar;C:\Documents and Settings\Administrator\jwsdp-1.1
\saaj-1.1.1\lib\saaj-api.jar;C:\Documents and Settings\Administrator\jwsdp-1.1
\saaj-1.1.1\lib\saaj-ri.jar;C:\Documents and Settings\Administrator\jwsdp-1.1
\saaj-1.1.1\lib\dom4j.jar;C:\Documents and Settings\Administrator\jwsdp-1.1
\jwsdp-shared\lib\jax-qname.jar;C:\Documents and Settings\Administrator\jwsdp-
1.1\jwsdp-shared\lib\commons-logging.jar;C:\Documents and 
Settings\Administrator\jwsdp-1.1\jwsdp-shared\lib\mail.jar;C:\Documents and 
Settings\Administrator\jwsdp-1.1\jwsdp-shared\lib\activation.jar'
[java] 'hello.HelloClient'
[java] 
[java] The ' characters around the executable and arguments are
[java] not part of the command.
[java] java.lang.NoClassDefFoundError: hello/HelloClient
[java] Exception in thread "main" 
[java] Java Result: 1

BUILD SUCCESSFUL
Total time: 1 second

Mime
View raw message