ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18129] - p4label hangs when setting 'locked' label state w/ JVM 1.3
Date Wed, 19 Mar 2003 08:46:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18129>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18129

p4label hangs when setting 'locked' label state w/ JVM 1.3





------- Additional Comments From levylambert@tiscali-dsl.de  2003-03-19 08:46 -------
I have tried to reproduce your bug in the following environment :
ant 1.5.2 + Win2K + Perforce P4/NTX86/2000.2/19837 (2001/01/03).
I have tried with JDK 1.3.0_02 and with J2SDK1.4.1_01. Perforce never hangs for 
me. 
My understanding is that Perforce tasks are executed through the Execute.java 
class. The blocking command in Execute.java is        waitFor(process); in line 
455 of Execute.java.
One difference in Perforce between ant1.5.1 and ant 1.5.2 is the class 
P4HandlerAdapter. 
see http://issues.apache.org/bugzilla/show_bug.cgi?id=16544
I submitted a patch for this class because Perforce was hanging on Win2k when 
Perforce would only produce output on stderr. I hope that this patch is not 
causing problems on Linux. 



I reproduced the fact that in verbose mode the label does not get locked.
I also found a fix for this problem (see attached file above)

Mime
View raw message