ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Gentle <j.kenneth.gen...@acm.org>
Subject Minimum CVS version for CVS tasks to support?
Date Mon, 17 Feb 2003 23:29:20 GMT
Hello all;

I've been working on a patch for the ChangeLogTask, and, while doing so, 
have seen a couple of areas for improvement in the CVS tasks in general 
(like support for "reallyQuiet" (aka -Q), making the ChangeLogTask extend 
AbstractCVSTask, etc.

There are some command line options available with CVS, at least with 1.11, 
that I think could make the change log task operate quicker, but I'm not 
sure if they're available on older revs of CVS.

So does the change log task need to support versions of CVS prior to 
1.11?  Given the recent security patches to the server CVS, seems like most 
folks should be using a 1.11 rev of CVS, but I guess there could be a lot 
of older clients out there too.

What's the consensus?

         Ken


=============================================================
J. Kenneth Gentle (Ken)    | Phone: (610) 255-0361
Gentle Software, LLC       | Email: j.kenneth.gentle@acm.org
=============================================================


Mime
View raw message