ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Conor MacNeill <co...@cortexebusiness.com.au>
Subject Re: Need some advice: Zip/Jar/Ear/War API backwards incompatibilities
Date Tue, 04 Feb 2003 13:50:37 GMT
Stefan Bodewig wrote:
> Hi all,
> 
> So what are we going to do?
> 
> Break the API twice with the next two releases?  Delay the fix for 1.6
> and break the API then?  Merge the new permissions stuff into 1.5.2
> and break the API there?
> 

I haven't studied the recent changes and implications in detail. This is 
just my quickfire reaction based on the assumption that a break is required.

IMHO, if a break is required, there should be just one.  Therefore I would 
bring the new permission stuff into 1.5.2. I don't want to delay fixing this 
issue to 1.6.

Conor



Mime
View raw message