ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17421] New: - in one particular case, param "default" in task project does not work
Date Wed, 26 Feb 2003 09:40:41 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17421>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17421

in one particular case, param "default" in task project does not work

           Summary: in one particular case, param "default" in task project
                    does not work
           Product: Ant
           Version: 1.5.1
          Platform: All
        OS/Version: Other
            Status: NEW
          Severity: Minor
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: pboyer@bmc.com


Apache Ant version 1.5.1 compiled on October 2 2002

if i run: 
>ant -buildfile example.xml
the default task of the project inside example.xml is runned. that's ok :->

but if i run:
>ant -DloginAndPassword=myuser,make -buildfile example.xml
the task "make" is runned instead of the default task. that's not ok :-< 
In version 1.4.1, there was no problem: the default task was runned even with 
the property -DloginAndPassword=make,make.

This is reproductible with the attached example.xml and the previous command 
for every -D property which the value is [a-z0-9]+,make. 
ex: foobar,make   a,make   b,othertarget ...

Mime
View raw message