ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17181] New: - Build fails while trying to get VSS files by label
Date Tue, 18 Feb 2003 21:03:08 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17181>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17181

Build fails while trying to get VSS files by label

           Summary: Build fails while trying to get VSS files by label
           Product: Ant
           Version: 1.5.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: bichojunk@hotmail.com


I am working on pulling source files for my project from Visual SourceSafe.  
Created a small ant file just to work on this issue.  At the version prompt, if 
I just hit return, I get all of my files.  If I put a version number such 
as '0.04.002', some of the files return but at arbitrary locations it breaks 
and fails.  I know the label exists in the VSS database because I get some 
results, just not all results.

===============  Build.xml ==========================================
<?xml version = '1.0' encoding = 'ISO-8859-1' ?>
<project name="VSS Ant Script" default="getit">

<property name="localDirectory" value="c:\ant_vss"/>


<target name="getit" description="pull files from vss" depends="setLabel">
	<delete dir="${localDirectory}"/>
	<mkdir dir="${localDirectory}"/>
	<vssget localPath="${localDirectory}"
		recursive="true"
		label="${vssLabel}"
		vsspath="/uber"/>
</target>

<target name="setLabel" description="get label from user">
	<input message="Version Number (return for latest)" 
addproperty="vssLabel"/>
</target>


</project>
=====================================================================
=================== Error Message ===================================
BUILD FAILED
file:C:/buildme/build.xml:13: Failed executing: ss Get $/uber -GLC:\ant_vss -I-
-R -VL0.04.002
        at org.apache.tools.ant.taskdefs.optional.vss.MSVSSGET.execute(MSVSSGET.
java:187)
        at org.apache.tools.ant.Task.perform(Task.java:319)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:336)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
        at org.apache.tools.ant.Main.runBuild(Main.java:610)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)

Total time: 29 seconds
=====================================================================
=============  My Input at the Prompt ===============================
0.04.002
=====================================================================

Mime
View raw message