ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17134] New: - Change <jdepend> task to support JDepend 2.5
Date Mon, 17 Feb 2003 17:03:57 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17134>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17134

Change <jdepend> task to support JDepend 2.5

           Summary: Change <jdepend> task to support JDepend 2.5
           Product: Ant
           Version: 1.5.1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: electricbob@alephnaught.com


I've talked with the author of JDepend - he's changed the program in 2.5 to
support class processing instead of source processing.  So, the <sourcespath>
element needs to be deprecated and a new element, I've picked <classespath>, added.

In addition, he's added the ability to apply ignore filters from outside the
mainline code.  I've added support for the <exclude> element to support ignoring
processing for packages of interest.

After adding this bug I'll see if I can attach context diffs for the change.  It
only affects the jdepend.html and JDependTask.java files.

Mime
View raw message