ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 16925] New: - Problem with paths when no basedir is set in the build file
Date Mon, 10 Feb 2003 11:22:55 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16925>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=16925

Problem with paths when no basedir is set in the build file

           Summary: Problem with paths when no basedir is set in the build
                    file
           Product: Ant
           Version: 1.5.1
          Platform: PC
               URL: http://www.netbeans.org/servlets/ReadMsg?msgId=463150&li
                    stName=nbusers
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: bard.heitmann@millum.no


When You execute a ant script on a diffrent drive than the build script is 
located it seems like ant have a problem with changing to the correct drive. 
This error occur when the basedir is not set and the paths in the build script 
is coded relative to the drive.

Eg.
d:\build.xml
Ant is installed on c: and executed from c:
Execute ant -buildfile d:\build.xml
This give all paths relative to c: instead of d: if the basedir is not set to 
d:\ in the script.


Check http://www.netbeans.org/servlets/ReadMsg?msgId=463150&listName=nbusers 
for a better explanation.

Mime
View raw message