ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joshua Allen" <jallen...@cogeco.ca>
Subject RE: bug report - <genkey>
Date Thu, 28 Nov 2002 00:38:19 GMT
I know this is hard to believe, I didn't believe it myself at first.  I don't know what's going
on here.  Have you tested this?  It
doesn't expand any of the properties, not just alias.

I've even echo'd the values of the properties before calling the task so I know that they
are set.

It's been broken since at least version 1.4.  It's not that big of a deal because <genkey>
is called so rarely during the life of a
project.

-Joshua

-----Original Message-----
From: Steve Loughran [mailto:steve_l@iseran.com]
Sent: Wednesday, November 27, 2002 7:22 PM
To: Ant Developers List
Subject: Re: bug report - <genkey>



----- Original Message -----
From: "Joshua Allen" <jallen181@cogeco.ca>
To: "Ant Developers List" <ant-dev@jakarta.apache.org>
Sent: Wednesday, November 27, 2002 14:46
Subject: bug report - <genkey>


> The <genkey> task does not expand property values.
> <genkey alias="${keystorealias}" keystore="${keystore}"
storepass="${keystorepassword}" keypass="${keypassword}" verbose="true">
>
> Will substitite ${keystorealias} for the alias instead of whatever the
property value is.

I think you may have left keystorealias unassigned. conversion from
${propname} to a value in any attribute assingment is done by ant, not the
individual tasks, so this is situation is pretty much impossible. It does
happen in element bodies, which we fix whenever we notice.

-steve


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message