ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craeg K Strong <cstr...@arielpartners.com>
Subject Re: Need help with backwards incompatible resolver change
Date Sun, 17 Nov 2002 04:10:51 GMT
Hello:

I think that is a reasonable way to go, as well.  Norm Walsh's
reply to my message indicated that he wanted to make
sure the new resolver got a fair degree of testing before
"shipping" with a ubiquitous product like Ant.

I agree with his conservatism, however, I don't think that
is a problem for Ant.  As I recall (thanks, Magesh! :)  release
1.5 went through several release iterations and was quite
thoroughly tested before it finally went out the door.

I expect that even if 1.6 alpha was released soon,
there would be plenty of time to shake out any bugs
that might be lingering.

So... that is my long-winded way of saying

+1

To the idea of going with resolver 1.1 (NOT 1.0)

What say we put it up to a vote, ant-devs?
If its a go, I will submit the (trivial) patch
that makes <xmlcatalog> compatible with resolver 1.1
(and therefore incompatible with 1.0).

--Craeg

Steve Loughran wrote:
> ----- Original Message -----
> From: "Craeg K Strong" <cstrong@arielpartners.com>
> 
>>(1) how pervasive is the 1.0 resolver jar?  Since Ant 1.6 is
>>not yet released, perhaps we can simply make it work with resolver
>>1.1 and mention in the Ant release notes that it requires a 1.1+
>>resolver.jar ?
> 
> I'm happy enough with requiring 1.1+, because resolver support hasnt ever
> shipped in ant; this is the time when we can change things at the risk of
> inconveniencing early adopters. Who by definition will be able to download
> the latest version of resolver



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message