ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14849] New: - JProbe tasks: executables cannot be found with JProbe 4.0.1
Date Tue, 26 Nov 2002 13:26:45 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14849>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14849

JProbe tasks: executables cannot be found with JProbe 4.0.1

           Summary: JProbe tasks: executables cannot be found with JProbe
                    4.0.1
           Product: Ant
           Version: 1.4.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: jan.sievers@sap.com


Hello,
I'm using the ant 1.4.1 JProbe tasks with JProbe 4.0.1 on Windows2000.
Due to the fact that the JProbe executables (e.g. jplauncher.exe) and dll's are 
now in <jprobe.home>/bin and the jars are now in <jprobe.home>/lib, the tasks

can no longer find these executables. It is not possible to work around this 
because in the checkOptions() method, you check if coverage.jar is in the same 
dir as the executables, and this is no longer the case. This is valid for all 
three JProbe tasks (jpcoverage, jpcovmerge, jpcovreport).
Also, the option "-jp_paramfile" of jpcovmerge.exe has changed its name to "-
paramfile" :(
As far as I can see in the CVS, this problem is not yet fixed in the newest 
version.

Best regards, Jan

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message