ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13397] - ant.bat causes a NoClassDefFoundError
Date Sun, 17 Nov 2002 03:00:42 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13397>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13397

ant.bat causes a NoClassDefFoundError





------- Additional Comments From charles.butterfield@nextcentury.com  2002-11-17 03:00 -------
The larger problem is that quoting the LOCALCLASSPATH at the point of execution 
(just after :runAnt label) conflicts with quoting selected path components.  If 
you do both, the inner quotes will prematurely terminate the quoting.  This 
problem is also encountered when the external CLASSPATH variable is already 
quoted.

It would seem that the solution is either:
a) don't quote LOCALCLASSPATH, just quote already unquoted components,
or
b) quote entire LOCALCLASSPATH, don't quote components, and unquote already 
quoted components (such as CLASSPATH).

I think (b) would be prettier (just one set of quotes at the end), but don't 
know how hard it is to strip quotes in DOS.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message