ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 14315] New: - Core Ant task : Repalce: non-performant
Date Wed, 06 Nov 2002 21:53:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14315>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=14315

Core Ant task : Repalce: non-performant

           Summary: Core Ant task : Repalce: non-performant
           Product: Ant
           Version: 1.4.1
          Platform: Other
        OS/Version: Other
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Core tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: gasiorpt@maritz.com


I am trying to replace a line containing xml attributes in a file.  There is 
only one such line in this file
According to the 1.4.1 docs and even the 1.5.1 docs this is how it would be 
done...
<replace file="${root}\utilwar\webApplication\WEB-INF\web.xml" summary="yes"> 
        	<replacetoken><![CDATA[<!--load-on-startup>-1</load-on-startup--
>]]>
        	</replacetoken>
        	<replacevalue><![CDATA[<load-on-startup>-1</load-on-startup>]]>
        	</replacevalue>
        </replace>
I then get the following in the verbose output of ant:
  [replace] Replacing in C:\marioworkspace\utilwar\webApplication\WEB-
INF\web.xml: <!--load-on-startup>-1</load-on-startup-->
                 --> <load-on-startup>-1</load-on-startup>
  [replace] Replaced 2 occurrences in 0 files.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message