ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <DDevie...@lgc.com>
Subject RE: [OFF-TOPIC] Proper IDEA/IntelliJ setup
Date Wed, 02 Oct 2002 20:57:50 GMT
Thanks Matt. It looks like it got us further along (i.e. we compile, but
cannot test for some other reason we have yet to sort out).

Thanks again, --DD

-----Original Message-----
From: Matt Bishop [mailto:matt.bishop@bea.com] 
Sent: Wednesday, October 02, 2002 3:08 PM
To: Ant Developers List
Subject: RE: [OFF-TOPIC] Proper IDEA/IntelliJ setup

In the Ant Build panel, Rt-click on the little Ant guy and select
Properties.  In the Properties window, under the Execution tab, there's a
"Run under custom JDK" checkbox; check that and pick 1.4.

Also, in the Project preferences, make sure the target JDK is 1.4, and
select the "support assert" checkbox to get your asserts to be recognized
properly.

Be sure to run Idea 2.6 under JDK 1.3.1, though, as it is really flakey
under 1.4.

Matt Bishop

-----Original Message-----
From: Erik Hatcher [mailto:jakarta-ant@ehatchersolutions.com]
Sent: Wednesday, October 02, 2002 12:41 PM
To: Ant Developers List
Subject: Re: [OFF-TOPIC] Proper IDEA/IntelliJ setup


IDEA 2.6?   I guess so, since the latest EAP versions require JDK 1.4.

I have the opposite environment, I'm running IDEA on JDK 1.4 and 
building on and for JDK 1.3.1_04.  I'm using build 638, and have my 
project properties to use the 1.3.1_04 JDK target and also set my Ant 
builds (Ant properties) to execute under that custom JDK version.  All 
has been well.

Not sure if that helps or not.

	Erik


Dominique Devienne wrote:
> Since I know many Ant committers are using IDEA, I'll give it a shot
here...
> 
> We're trying to use the Ant integration in IntelliJ. Are required by
> IntelliJ, we start it under JDK 1.3.1. Our project requires JDK 1.4+ (uses
> assert keyword and new 1.4 APIs), and the build.xml assumes it's running
> under 1.4 (not setup for cross-JDK compilation).
> 
> Apparently, IntelliJ runs the Ant build in the JDK it was started on (I'm
> not sure if it's the same VM it running itself with), thus 1.3.1, when the
> build will only work with a JDK 1.4+!!!
> 
> Does anyone know a fix/turn around for this situation? Thanks, --DD
> 
> --
> To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>
> 
> 
> 


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message