ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13879] New: - Env variable ANT_ARGS not used in ant.bat
Date Wed, 23 Oct 2002 13:04:24 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13879>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13879

Env variable ANT_ARGS not used in ant.bat

           Summary: Env variable ANT_ARGS not used in ant.bat
           Product: Ant
           Version: 1.5.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Wrapper scripts
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: roberto.vichi@rossomaltese.it


The ANT_ARGS environment variable in ant.bat is not used (as it is in ant shell
script).
I fixed this with the following lines, reported as diff output:
-----
18a18,24
rem [
rem 2002-10-22, Roberto J. Vichi, Fixed bug: ANT_ARGS not recognized
rem set ANT_CMD_LINE_ARGS=%1

if "%ANT_ARGS%"=="" set ANT_CMD_LINE_ARGS=%1
if not "%ANT_ARGS%"=="" set ANT_CMD_LINE_ARGS=%ANT_ARGS% %1
rem ]
-----
Thanks for interest.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message