ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 13397] New: - ant.bat causes a NoClassDefFoundError
Date Tue, 08 Oct 2002 07:25:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13397>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13397

ant.bat causes a NoClassDefFoundError

           Summary: ant.bat causes a NoClassDefFoundError
           Product: Ant
           Version: 1.5.1
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Wrapper scripts
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: starscream_au@yahoo.com


Running ant at the command line results in this error:

Exception in thread "main" java.lang.NoClassDefFoundError: Files\Java\j2sdk1/4/1
\lib\tools/jar;C:\Program Files\Ant\lib\optional/jar;C:\Program Files\Ant\lib\an
t/jar;

Note that the tools.jar path is trunicated.

If I change line 62 of ant.bat from:

if exist "%JAVA_HOME%\lib\tools.jar" call "%ANT_HOME%\bin\lcp.bat" "%JAVA_HOME%
\lib\tools.jar"

to as it appeared in ant 1.5. ie remove the quots from around the tool.jar path:

if exist "%JAVA_HOME%\lib\tools.jar" call "%ANT_HOME%\bin\lcp.bat" %JAVA_HOME%
\lib\tools.jar

then ant runs normally.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message