ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Bernhardt <mbernha...@swsgmbh.de>
Subject Crash after creation of last jar.
Date Wed, 11 Sep 2002 10:49:15 GMT
Hi all,

I changed recently to 1.5 after using 1.2 for over a year.
My problem is now, that after the creation of the last
jar file, ant dies. (1.5.1beta still has the problem)

Log:

...
package-server:
      [jar] Building jar: /home/sws/spieljoch.tele/build/server.jar

package-client:
      [jar] Building jar: /home/sws/spieljoch.tele/build/client.jar

package-dummy:
      [jar] Building jar: /home/sws/spieljoch.tele/build/dummy.jar

BUILD FAILED
java.lang.NullPointerException
        at
org.apache.tools.zip.ZipOutputStream.finish(ZipOutputStream.java(Compiled
Code))
        at
java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:139)
        at org.apache.tools.ant.taskdefs.Zip.execute(Zip.java:402)
        at org.apache.tools.ant.Task.perform(Task.java:319)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:336)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)

        at
org.apache.tools.ant.Project.executeTargets(Project.java:1250)
        at org.apache.tools.ant.Main.runBuild(Main.java:610)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)

Total time: 1 minute 46 seconds
java.lang.NullPointerException
        at
org.apache.tools.zip.ZipOutputStream.finish(ZipOutputStream.java(Compiled
Code))
        at
java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:139)
        at org.apache.tools.ant.taskdefs.Zip.execute(Zip.java:402)
        at org.apache.tools.ant.Task.perform(Task.java:319)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:336)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)

        at
org.apache.tools.ant.Project.executeTargets(Project.java:1250)
        at org.apache.tools.ant.Main.runBuild(Main.java:610)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)


If I remove the dummy.jar, then the client.jar crashes.
If I insert a dummy2.jar after dummy,jar, then dummy.jar get created
right and
it crashes after dummy2.jar.

In general all the jar-files are created on disk, but the last one is
not ok.
The VM does not like it, but with the jar shell tool I can decompress
it.
The content looks ok.

Some more info:

build.xml

....
<!--
===================================================================  -->

<!--  Creates the server class
package                                     -->
<!--
===================================================================  -->

<target name="package-server" depends="compile">
  <jar jarfile="${build.dir}/server.jar" basedir="${build.dest}"
includes="de/**" excludes="de/db/sws/satzdialoge/client/**" />
</target>
<!--
===================================================================  -->

<!--  Creates the client class
package                                    -->
<!--
===================================================================  -->

<target name="package-client" depends="compile">
  <jar jarfile="${build.dir}/client.jar">
    <fileset dir="${build.dest}"
             includes="de/**"

excludes="de/db/sws/satzdialoge/dbobject/**,de/db/sws/satzdialoge/var/**,de/db/ktr/**"
/>
  </jar>
</target>
<!--
===================================================================  -->

<!--  Creates the dummy class
package                                     -->
<!--
===================================================================  -->

<target name="package-dummy" depends="compile">
  <jar jarfile="${build.dir}/dummy.jar">
    <fileset dir="${build.dest}"
             includes="de/**"

excludes="de/db/sws/satzdialoge/dbobject/**,de/db/sws/satzdialoge/var/**,de/db/ktr/**"
/>
  </jar>
</target>
<!--
===================================================================  -->

<!--  Creates the class
packages                                           -->
<!--
===================================================================  -->

<target name="package"
depends="package-server,package-client,package-dummy" />
...


java version "1.3.0"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.3.0)
Classic VM (build 1.3.0, J2RE 1.3.0 IBM build cx130-20010626 (JIT
enabled: jitc))


Is this a known bug ?
Havent found something in the archives.

- markus


Mime
View raw message