ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cost...@covalent.net
Subject Re: 1.1 compat ( was Re: Death of a mutant ...
Date Fri, 12 Jul 2002 03:36:35 GMT
On Thu, 11 Jul 2002, Diane Holt wrote:

> --- costinm@covalent.net wrote:
> > It seems many commiters feel supporting JDK1.1 is no longer necesary
> > and having ant1.5 the last one supporting it is reasonable. All it
> > takes is a vote.
> 
> I thought the idea was to keep Ant1.x 1.1-compatible, and make the break
> at Ant2. Did that change over the course of this thread and I missed it?

I thought the idea was that ant2 will have those famous incompatible API/
build.xml changes ( or will just be the next release after 1.9 :-).

It seems many people want to stop supporting 1.1 - I'm usually against, 
but if indeed nobody uses 1.1 anymore ( for development at least ) I don't 
see why it has to wait until ant2. 

Each version includes the features and supports whatever the commiters 
decide. We've seen a lot of pain in keeping 1.5 compatible with JDK1.1,
and having a better class loading in 1.6 would outweight 
the lost of 1.1. 

Costin


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message