ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jon Skeet" <jon.sk...@peramon.com>
Subject Why stop at JDK1.2? Only semi-serious question...
Date Sat, 13 Jul 2002 21:41:57 GMT
All this discussion about whether or not to drop JDK 1.1 support has
just got me thinking: why stop there? Just as almost everyone has a
Java2 version of the JDK, doesn't almost everyone have 1.3+ ?

Don't jump on me at once: I know not everyone has. However, I don't know
how large that divide is, nor do I know how much benefit requiring 1.3+
would give us. I just think it's worth asking the question *now* rather
than waiting until there's a situation which would be easier to handle
in 1.3.

I suspect the answer is that there's not a lot that 1.3 gives us that
1.2 doesn't, in terms of API. Here's what the 1.3 "Summary of New
Features" list has:

o JNDI (probably irrelevant to the core)
o RMI (ditto)
o Various client-only things such as Swing, AWT, Java Sound etc
enhancements
o Security (probably not an issue?)
o Networking (probably irrelevant to the core)
o Reflection enhancements (dynamic proxy classes - these have always
struck me as cool, but I've never actually used them. I don't know how
to predict whether or not they'd be useful to Ant.)
o Serialization (I try to avoid this in general, and I suspect Ant
doesn't need to use it)
o Collections framework enhancements - nothing huge, as far as I can see
o Enhancements in java.{util,math,lang} - as far as I can see, only
java.util.Timer is likely to be particularly useful to Ant, and can be
reasonably easily implemented by us anyway, I'm sure.
o JPDA (Java Platform Debugger Architecture) - More likely to be useful
for extra tasks, I'd have thought (I hadn't considered using Ant in the
context of a debugger before - might think about that some more...)
o Tool and performance changes are irrelevant to the core of Ant, I
suspect


I can't see anything particularly compelling in the above, but if I've
missed anything, do let me know.

On the other side of things, what platforms are there which make it
difficult to get 1.3 compatibility? gcj is the first "suspect" as it
were, but that's a mere guess from someone who's never used it...

Just some random Saturday night musings, anyway.

Jon

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message