ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 11207] New: - ExecuteWatchdog class is not compatible with 1.4 version of it
Date Fri, 26 Jul 2002 14:35:48 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11207>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=11207

ExecuteWatchdog class is not compatible with 1.4 version of it

           Summary: ExecuteWatchdog class is not compatible with 1.4 version
                    of it
           Product: Ant
           Version: 1.5
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Core tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: martin.brehovsky@sun.com


In our code we're using class, which inherits from
org.apache.tools.ant.taskdefs.ExecuteWatchdog. The problem is, that in our
constuctor we call super(int). Because in 1.5 this constructor was changed
contain 'long timeout' as an argument, our code does not work with 1.5. I know
it can be easily changed, but in this case it will not work with 1.4.*, which is
crucial for the time being.

Would it be possible to add a constructor with 'int timeout' argument for
compatibility reasons to the mentioned class. It would really help. Thanks.

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message