ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 10704] - EJBC Crash when running weblogic
Date Tue, 16 Jul 2002 16:55:58 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10704>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=10704

EJBC Crash when running weblogic





------- Additional Comments From j_a_fernandez@yahoo.com  2002-07-16 16:55 -------
I need some help trying to trace this issue.
One thing I notice is that the implementations are calling weblogic with a 
different combination of parameters, the old implementation is calling this 
way:

Forking C:\bea\jdk131\jre\..\bin\java.exe -classpath C:\bea\wlserver6.1
\lib\weblogic.jar;C:\projects\HEAD\pita\build\cellectivity-
vm.jar;C:\projects\HEAD\pita\lib\log4j-1.2beta4.jar weblogic.ejbc20 
C:\projects\HEAD\pita\build\o2\jars\container-generic.jar 
C:\projects\HEAD\pita\build\o2\jars\container.jar

The new implementation is doing the following:

Executing 'C:\bea\jdk131\jre\bin\java.exe' with arguments:
     [ejbc] '-classpath'
     [ejbc] 'C:\bea\wlserver6.1
\lib\weblogic.jar;C:\projects\HEAD\pita\build\cellectivity-
vm.jar;C:\projects\HEAD\pita\lib\log4j-1.2beta4.jar'
     [ejbc] 'weblogic.ejbc20'
     [ejbc] '-classpath'
     [ejbc] 'C:\projects\HEAD\pita\build\classes'
     [ejbc] 'C:\projects\HEAD\pita\build\o2\jars\container-generic.jar'
     [ejbc] 'C:\projects\HEAD\pita\build\o2\jars\container.jar'

You can see the usage of the -classpath in the parameters for weblogic. This 
may be part of the problem. The old implementation creates a jar with 168 
classes while the new one puts 169. I am adding an attachment with the verbose 
output of the task (the segment I consider relevant). I have modified the use 
of the task a little to be the following:

        <ejbjar descriptordir='${gendir.core}'
                srcdir='${classes}'
                manifest='${container.manifest}'
                dependency='full'
                naming='directory' >
            <classpath>
                <!--
                <path refid='global.classpath'/>
                -->
                <pathelement location="${classes}"/>
            </classpath>
            <weblogic destdir='${jardir.core}'
                      rebuild='true'
                      keepgenerated='${ejbc.debug}'
                      noEJBC='${noejbc}'>
                <wlclasspath>
                    <path refid='weblogic.and.libs'/>
                </wlclasspath>
            </weblogic>
            <dtd publicId='-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 
2.0//EN'
                 location='${j2ee.descriptors}/ejb-jar_2_0.dtd'/>
            <include name='**/ejb-jar.xml'/>
        </ejbjar>

Can someone give me any clues on this issue?

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message