ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jose Alberto Fernandez <j_a_fernan...@yahoo.com>
Subject RE: Ant Security
Date Fri, 12 Jul 2002 11:34:47 GMT
 --- Ara Abrahamian <ara_e_w@yahoo.com> wrote: 
> 
> Imho a better solution is: define in antlib's
> deployment descriptor
> files which jars the task depends upon and show an
> error message if that
> jar is not found. That's exactly what we're doing in
> XDoclet 1.2. So if
> you use webdoclet but javax.servlet is missing we
> show an error message
> according to the <class-dependency/> of the
> module.xml descriptor file.
> 

I think we all are in the same wavelength on this. The
only additional thing we are talking about is to be
able to run a target "pickNeededJars" which may use
<jjar> to pick the correct versions.

Now it would be nice if to achieve that it would use
the information already in the antlib as oppose to
me needing to maintain my own set of dependencies.

Something like:

 <antlib update="true" overwrite="false" .../>

Which will use <jjar> to bring those things that are
out of date with respect to the version of the library
I am running.

In the regular course of things i would just be doing:

 <antlib update="false" .../>

Jose Alberto


__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message