ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9579] New: - "newenvironment" attribute seems not working for "java" task
Date Mon, 03 Jun 2002 15:53:25 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9579>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9579

"newenvironment" attribute seems not working  for "java" task

           Summary: "newenvironment" attribute seems not working  for "java"
                    task
           Product: Ant
           Version: 1.5Beta2
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: redha@clientsoft.com


Using Ant 1.5beta2 and Jax obfuscator.

When I tried to pass new environmenent variable to jax to be able to use the 
JDK 1.1, the log shows that is still using the JDK 1.3.1_03(env for ant).

build task:
----------
      <java classname="com.ibm.jax.Batch" 
			fork="true" 
			dir="${basedir}/${crypteScript}" 
			failonerror="true"
			newenvironment="true">
			<env key="JAVA_HOME" path="${JDK1_1}"/>
			<env key="PATH" path="${JDK1_1}/bin"/>
			<env key="CLASSPATH" 
path="${JDK1_1}/lib/classes.zip;${crypteTool}"/>
			<sysproperty key="HOME" path="${basedir}/
${crypteScript}" /> 
			<arg value="${script}.jax"/>
			<classpath>
			   <pathelement location="${JDK1_1}/lib/classes.zip" /> 
			   <pathelement location="${crypteTool}" />
			</classpath>
	   </java>

log :
---
     [java] jax V6.1-Monday-Oct-18-1999 Copyright IBM 1997-1999. All rights 
reserved.

     [java] More info: http://www.alphaWorks.ibm.com/tech/jax
     [java]            http://www.research.ibm.com/jax


     [java] Configuration file name is "script.jax"
     [java] JDK used is Sun Microsystems Inc. version 1.3.1_03

Did I miss something? As Jax doesn't work with jdk greater than 1.1 I really 
need to able to run jax with the jdk 1.1.

Thanks.

Redha

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message