ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cost...@covalent.net
Subject Re: Ant on java 1.4
Date Wed, 22 May 2002 16:39:50 GMT
On 21 May 2002, Stefan Bodewig wrote:

> > In fact many are setting 'classic' compiler in build.xml, so they'll
> > not even compile with JDK1.4 out of box.
> 
> Well, they better should have never done so 8-).  Seriously, this is
> something that needs to get addressed (fall back to modern as we do
> the other way around for JDK 1.2 and 1.1).

+1

I'll commit a fix.
 
 
> > My point is that most people just don't know about this new
> > wonderfull 'feature' of JDK1.4.
> 
> I simply don't want to turn the JDK 1.4 feature into an Ant 1.5
> feature of "why does Ant force me to set the target attribute if I
> don't care for JDK 1.1".

> Documenting it in <javac>'s doc and on a 1.4 issues page is better
> than implicitly setting command line switches just because we feel the
> default value is wrong.

Ok. I'll get all the projects I am commiter and have 1.1 support updated.

Again, my problem is not the fact that in most cases we'll generate
code that doesn't work with 1.1 ( it's Sun fault and goal ). My 
problem is that jikes and other compilers migh have problems 
working with the compiled code. JDK1.1 is not the only consumer 
for the 1.1 class version tag, compilers use it too and this 
may brake non-Sun compilers too, not only 1.1 VMs.

Costin 

 


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message