ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: Ant on java 1.4
Date Fri, 17 May 2002 14:20:09 GMT
On 17 May 2002, Stefan Bodewig wrote:

> On Thu, 16 May 2002, <> wrote:
> > Would it be a problem if we set the default to "1.1", and let people
> > override it if they want ?
> Yes it would - you wouldn't have a way to use no -target switch at all
> and it would break backwards compatibility.

If you use JDK1.1-JDK1.3, the default is 1.1 anyway ( on javac ). If you 
don't specify any -target, nothing change. If you specify a -target, it'll 
be honored. No behavior change here.

If you use JDK1.4, the current default is 1.2. That brakes backward 
compatibility for all projects who target JDK1.1. If we default to 
-target1.1, we generate code that is identical with what 1.1 generates 
without any change in build.xml. If people include an explicit 
-target, then it will be used.

My point is that we'll be soon in a nightmare situation with support for 
1.1. Many projects _require_ 1.4 to be fully built, and all those will
not work with JDK1.1. Changing all build.xml files is unlikely as most
projects are not aware of that. Even ant doesn't do it now.


To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message