ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Wannamaker" <Ke...@Wannamaker.org>
Subject RE: DefaultJspCompilerAdapter change in 1.5 branch breaks Tomcat
Date Wed, 22 May 2002 13:11:46 GMT
Stefan,
Since these tomcat tools only work with Ant 1.5 
(JspC isn't in 1.4.1), I'll just change the tool.
I'm a little perplexed, though, that the methods
were pulled rather than deprecated, assuming they
existed prior to 1.5.  (Those should be dep 
warnings we get, not compile errors :-)

Keith

| -----Original Message-----
| From: Stefan Bodewig [mailto:bodewig@apache.org]
| Sent: Wednesday, May 22, 2002 4:59 AM
| To: ant-dev@jakarta.apache.org
| Subject: DefaultJspCompilerAdapter change in 1.5 branch breaks Tomcat
| 
| 
| Steve, Keith,
| 
| could you please look at 
| <http://cvs.apache.org/~bodewig/gump/20020522/jakarta-tomcat.html>?
| 
| When Steve changed from Commandline to CommandlineJava, Keith's
| Tomcat3 precompiler has been broken.  This means it will not work in
| Ant 1.5 unless Keith adapts to the new method signature at the same
| time.
| 
| I think the easiest way to deal with the current issue was to merge
| the 1.5 branch changes for this class into the main branch and change
| Tomcat3Precompiler at the same time.
| 
| Stefan
| 
| --
| To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
| For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>
| 
| 

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message