ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GOMEZ Henri" <hgo...@slib.fr>
Subject RE: [JPackage-devel] ant 1.5b1 RPM advice
Date Tue, 07 May 2002 15:29:57 GMT
>> I agree but jakarta rpm users may complains if they don't
>> find optional tasks for there vaj, weblogic...
>So why bother by building from source if you just want to 
>provide a complete 
>standalone application as a working rpm ? Just use original 
>binaries as 
>source, as we do with all our non-free packages.

ant is OSS and only some minors classes couldn't be compiled,
I've got it loaded on my Eclipse IDE and only weblogic, vaj,
starteam and jdk 1.4 dependant stuffs couldn't be built.

I want to build ant from source just to make sure that
ant core is really rebuilt from source.

There is the following existing rpms at jakarta.org or jpackage.org for :

activation / jaf
bcel
bsf
jaxm (xml-api)
junit
log4j
mail (javamail)
netcomponents
oro
regexp
xalan1 (xml compat)


miss the following packages :

ejb => Sun stuff should be nosrc ;[
jdepend => who could do it ?
netrexxc => who could do it ?
xslp (1.1) => who could do it ?

stuff for vaj, weblogic, starteam could be build with Jon' 
InterfaceFaker.

for jdk 1.4 support, I'll just need to build against JDK 1.4
instead of jikes or IBM SDK 1.3.1



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message