ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rob Oxspring" <roxspr...@imapmail.org>
Subject Re: Selectors documentation and a Reference bug fix
Date Tue, 07 May 2002 13:45:13 GMT

----- Original Message -----
From: "Bruce Atherton" <bruce@callenish.com>
To: "Ant Developers List" <ant-dev@jakarta.apache.org>
Sent: Monday, May 06, 2002 10:07 PM
Subject: Re: Selectors documentation and a Reference bug fix


> At 12:54 PM 5/6/2002 -0700, Diane Holt wrote:
> >This is the first time I've had a chance to look through (okay, more like
> >glance through, since today's a busy day) this stuff, so forgive me if
I'm
> >a bit late in making the following suggestions:
>
> All feedback is very much appreciated at all times.
>
> >   - For consistency, wouldn't <selectset> be better than <select>?
>
> I'm happy to call it whatever people want.

I know its a bit pedantic but it isn't actually a "set" of selectors - a
"set" doesn't give any indication of the relationship between the selectors
inside it, hence the development of the and/or (and friends) containers .
Personally the word "selector" makes the most sense as you are defining a
single (possibly compount) object to perform selections. Just my 2p.

>
> >   - Also, I think I'd rather see the nested element names drop the
> >     "select" part, since I think it's a bit redundant to have
> >     <containsselect>, <dateselect>, etc., when it's already clear
> >     it's a selector since it's nested in a <select> (or <selectset>,
> >     if you agree with my first suggestion). Plus, the element names
> >     get harder to read and to type.
>
> You are right, it would be cleaner to drop the "select" part (although it
> isn't necessarily in a <select{set}> if it is in a <fileset>). Is it too
> late for that kind of a change, though?

I'd say change it now and get it right before release - it only got in for
the beta and thats only a week old so I wouldn't think too many people are
using the current names.  If it is a problem then how about including some
aliases to the old names?

IMHO It seems right that the selectors side should be allowed a little more
change than most things while in beta since there was minimal time for
review of the final code.

Rob

>
> >(BTW: The attributes table for the <containselect> element looks to have
a
> >pick&put error.)
>
> Yeek, sounds terrible. Oh, I see what you mean by that. Not enough cut and
> paste care. Thanks for catching it.
>
> It's fixed in my copy now. Should I resubmit the whole tarball or just the
> one file?
>
>
>
> --
> To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>
>
>
>


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message