ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magesh Umasankar" <umag...@apache.org>
Subject Re: Ant on java 1.4
Date Fri, 17 May 2002 20:27:31 GMT
I need to build Ant with JDK 1.4 because to generate
a total build, there are dependencies on JDK 1.4 in
build.xml.  However, if I specify target=1.1, I run
into other problems for which I have launched a
separate thread of discussion...

How do you all out there manage a complete Ant build
using JDK 1.4 so that the distro is 1.1 compatible as
well?

Cheers,
Magesh

*************************************************************
*  Optimist: A person who while falling from the            *
*  Eiffel tower says in midway "See I am not injured yet."  *
*************************************************************
----- Original Message -----
From: <costinm@covalent.net>
To: "Ant Developers List" <ant-dev@jakarta.apache.org>
Sent: Friday, May 17, 2002 4:19 PM
Subject: Re: Ant on java 1.4


> On Fri, 17 May 2002 costinm@covalent.net wrote:
>
> > Stefan,
> >
> > I did a quick grep and no jakarta or xml project is using target
> > attribute. In fact many are setting 'classic' compiler in build.xml, so
> > they'll not even compile with JDK1.4 out of box.
> >
> > My point is that most people just don't know about this new wonderfull
> > 'feature' of JDK1.4. I didn't know until it bit me.
>
> BTW, it seems jikes will not work if 'target=1.2' is used - so a system
> build with 1.4 won't be useable with jikes ( and I suspect other
compilers ).
>
>
> Costin
>
>
>
>
> >
> >
> >
> > Costin
> >
> >
> >
> > > > That brakes backward compatibility for all projects who target
> > > > JDK1.1.
> > >
> > > I'm not taking about JDK 1.4 breaking backwards compatibility - we
> > > both know it does in too many places to enumerate them - but backwards
> > > compatibility to Ant 1.4.
> > >
> > > If I don't care for JDK 1.1, I won't set the target option in Ant 1.4
and
> > > use the compiler's default value.  If I do, I better set the target
> > > option instead of relying on Ant (which I can't if my users may be
> > > stuck with Ant 1.4 anyway).
> > >
> > > > Many projects _require_ 1.4 to be fully built, and all those will
> > > > not work with JDK1.1.
> > >
> > > If these projects want to be compatible to JDK 1.1, they should make
> > > that decision consciously and set the target attribute explicitly
> > > IMHO.
> > >
> > > Stefan
> > >
> > > --
> > > To unsubscribe, e-mail:
<mailto:ant-dev-unsubscribe@jakarta.apache.org>
> > > For additional commands, e-mail:
<mailto:ant-dev-help@jakarta.apache.org>
> > >
> > >
> >
> >
> > --
> > To unsubscribe, e-mail:
<mailto:ant-dev-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
<mailto:ant-dev-help@jakarta.apache.org>
> >
> >
>
>
> --
> To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message