ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Alberto Fernandez" <j_a_fernan...@yahoo.com>
Subject Re: Javadoc task
Date Sat, 04 May 2002 17:12:36 GMT
From: "Stefan Moebius" <stmoebius@yahoo.com>

> --- Diane Holt <holtdl@yahoo.com> wrote:
> > --- Stefan Moebius <stmoebius@yahoo.com> wrote:
> > > Just a humble request:
> > > Could you support the "-subpackages" option from Javadoc 1.4?
> > > The reason is that packagenames ending with ".java" are assumed to
> > be
> > > single source files since 1.4. This breaks, for example, the
> > > Jakarta-Maven javadoc generation. Using "-subpackages
> > > package1:package2..." get's this straight.
> > 
> > See:
> >   http://marc.theaimsgroup.com/?l=ant-user&m=101952493426201&w=2
>  
> Hi Diane, 
> Yes, I've considered this and I guess it works. The problem with this
> is that you need different build files depending on the JDK version you
> use.  And although I might use this for myself I don't think the Maven
> team would want to stick to this work-around.
> 

Needing different build files is kind of extreme, don't you think? :-)
All what you need is two diferent targets for doing the compile:

<target name='compile' depends='compile-1.3, cpmpile-1.4'/>

<target name='compile-1.3' unless='using-jdk14'>
 ...
</target>

<target name='compile-1.4' if='using-jdk14'>
...
</target>

This should solve your problem just fine.

Jose Alberto



--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message