ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <cost...@covalent.net>
Subject Re: optional.jar required to bootstrap?
Date Mon, 22 Apr 2002 16:59:02 GMT
On 22 Apr 2002, Stefan Bodewig wrote:

> On Sun, 21 Apr 2002, Erik Hatcher <jakarta-ant@ehatchersolutions.com>
> wrote:
> 
> > Actually, our src/etc/manifest file still mentions crimson.jar.
> 
> It also mentions parser.jar, which we've dropped with 1.3, and
> xalan.jar, which we've never shipped so far.  It also mentions
> optional.jar in the manifest for optional.jar.

Having crimson.jar in the manifest doesn't hurt - but we should also
include xmlApis.jar, xercesImpl.jar, xerces.jar. 

This will cover most JAXP versions and packaging schemes ( while 
allowing "java -jar ant.jar" to work ). At least short term - 
the latest new packaging scheme with xmlApis is quite recent, many 
projects may still use crimson, etc.

( that's for the case ant.jar is integrated and used in a project
like tomcat )


Costin


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message