ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 7325] - uptodate task mergemap directory rooting problem
Date Fri, 29 Mar 2002 19:42:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7325>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=7325

uptodate task mergemap directory rooting problem





------- Additional Comments From craiglaurent@yahoo.com  2002-03-29 19:42 -------
using "location", Here is the funky line I get:
 [uptodate] test\util\List.class added as
D:\projects\AntBug\build\classes\D:\projects\AntBug\build\application.jar
doesn't exist.
note how it appends a full path after the other full path.  "D:\....D:\..."

I have created a test project to mimic this, and have it down to a bare bones.
I can get it to reproduce...but I don't really understand why it happens.

Here is the basic core of it (make a classes.dir, and put some *.class files in it)
  <!-- build locations -->
  <property name="build.dir"            location="./build" />
  <property name="classes.dir"          location="${build.dir}/classes" />


  <!-- =================================================================== -->
  <!-- check if the jar file needs re-making                               -->
  <!-- =================================================================== -->
  <target name="need-rejar">

     <uptodate property="jar.notRequired">
       <srcfiles dir="${classes.dir}" includes="**/*.class" />
       <mapper type="merge" to="${build.dir}/application.jar" />
     </uptodate>

  </target>
  

  <!-- =================================================================== -->
  <!-- jar up classes to be used by client application                     -->
  <!-- =================================================================== -->
  <target name="jar" depends="need-rejar" unless="jar.notRequired">
    <jar jarfile="${build.dir}/application.jar" basedir="${classes.dir}" />
  </target>


if you run "ant jar", it works just fine, as you mention.
when I run "ant need-jar", I get the problem.  (or if I remove the "jar" line
from inside the jar target).

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message