ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <>
Subject Re: ChangeLog task
Date Fri, 29 Mar 2002 02:15:29 GMT
On Fri, 29 Mar 2002 12:34, Diane Holt wrote:
> --- Peter Donald <> wrote:
> > I just added a changelog task to ants cvs.
> Since this is a CVS-centric task, it might be better to call it <cvslog>
> rather than <changelog>.

I just copied the name from the alexandria CVS ;) 

that could work - maybe <cvschangelog/> or something so as not to mix up with 
the "cvs log" command. What does everyone think? 

> > docs/manual/CoreTasks/changelog.html
> There's a few booboos :) 


> You have 'daysinpast' in the attributes table,
> but 'days' in an example. 

woops - fixed. "days" was the name used in the mavern project but I renamed 
it to daysinpast to try and make it clearer - not sure if I achieved that end 

> And I'm not
> sure what happened to the CDATA section in the example output -- are the
> square brackets supposed to be nested that way? 

yep - thats the way it is supposed to look.

> (There's also some
> formatting and other nits I can clean up for you, if you want.)

That would be great - as you can tell I suck at all these sorts of things ;)

> Also, the description for 'daysinpast' is a bit
> mangled. And, if I'm reading it right, it seems to only be valid in
> combination with the 'start' attribute, so that should probably get
> included in the description. There should be a "Parameters specified as
> nested elements" heading before "user" and its params table. 
> > It also allows filtering of entrys to occur. It allows you to specify
> > "start"  (ie date of earliest change you want to report), "daysinpast"
> > (how many days in past to set "start" to and "end" (the latest change
> > you want to report). I really dislike these attribute names but couldn't
> > think of anything better. If others can think of better names then go
> > for it.
> Are the 'start' and 'end' dates exclusive? If they are, then 'after' and
> 'before' might be better. 'daysinpast' is kind of gruesome, but at least
> it says what it does :)  I'm not sure if something like 'numberofdays' is
> really all that much better, but 'days' might not be self-explanatory
> enough (but maybe it is -- it's certainly shorter :)

well what start/end/daysinpast are meant to do is define a range of time that 
is included in the report. So start (or maybe we could name it "from") saids 
that every change reported must occur on or after this date. end (or maybe 
"to") saids that every change reported must occur on or before this date. So 
you can have both a start and an end specified or just one or neither.

Im not if that is that any clearer? 

daysinpast is actually meant to support the ability to "get the changes in 
the last 10 days". So it should be incompatible with "start" but conceivably 
you could set "end". I don't know of a good way of explaining (or naming it). 
Maybe we could have it as "startOffsetFromNow" or something like that. Not 

Feel free to rename it to whatever you think is easier to understand ;)



"The perfect way is only difficult for those who pick and choose.  Do not
like, do not dislike; all will then be clear.  Make a hairbreadth
difference and heaven and earth are set apart; if you want the truth to
stand clear before you, never be for or against." - Bruce Lee

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message