ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diane Holt <hol...@yahoo.com>
Subject Re: suggestion for if/unless syntax change
Date Wed, 20 Mar 2002 19:48:11 GMT
--- stephan beal <stephan@einsurance.de> wrote:
> i have a suggestion for the if/unless clauses:
> 
> Rename them to ifset and unlessset. The reason for this is that they
> have behaviour which is counter-intuitive for most programmers
> in that they work if the var is set to *any* value, regardless of 
> the true/false interpretation of the var.

I don't find it counter-intuitive. The if/unless attributes take the name
of a property, not a reference to its value (ie., "foo", not "${foo}") --
nor does setting a property to "true" or "false" mean anything special,
generally, since they're just the strings t-r-u-e and f-a-l-s-e.

Diane

=====
(holtdl@yahoo.com)



__________________________________________________
Do You Yahoo!?
Yahoo! Sports - live college hoops coverage
http://sports.yahoo.com/

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message